package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-zA-Z]{1,2}\d{3,5}[a-zA-Z]?\b`)
var str = `M394
,MP4245)
TD493!
X4958A
V49534@
U394U
A5909.
TED492
R32
R4!3
U394UU
A5909AA
5349A`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}