// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[a-zA-Z]{1,2}\d{3,5}[a-zA-Z]?\b").unwrap();
let string = "M394
,MP4245)
TD493!
X4958A
V49534@
U394U
A5909.
TED492
R32
R4!3
U394UU
A5909AA
5349A";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}