# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?(DEFINE)(?<hours>[0-2]\d{1})(?<minutes>[0-5]\d{1})(?<seconds>(?&minutes))(?<milliseconds>\d{3})(?<separator>\-\-\>)(?<timecode>((?&hours):)?(?&minutes):(?&seconds)\.(?&milliseconds)))^(?<start>(?&timecode))\ {1,}-->\ {1,}(?<end>(?&timecode))(.*)$"
test_str = "00:59:59.100 --> 00:00:00.000asdasdasdkjsdkjfhsdkjgfhdkfjhglaksjd"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.