import Foundation
let pattern = #"[Aa]dquis|[Cc]ompra|[Ff]inanz|[Oo]perac|[Aa]dministra"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
NA
Jefa Sala de Operaciones y CEyE
Biomedica
Jefa de Administración Clínica de Enfermería
Cotizador del Depto. Adquisiciones
Jefa del Departamento de Enseñanza
Jefe de Cirugia
Departamento de adquisciones
Jefe Departamento de Imagen
Executive Director
Jefe del Departamento de Ecocardiografía
Jefe del Departamento de Electrocardiografía
Departamento de Medicina Nuclear
Coordinador y Técnico del Depto de Radiología
Jefe de Adquisiciones Medico Hospitalarias
Jefa del Departamento de Enseñanza
Programadora de sistemas
Asistente de Contraloría
Director de Finanzas
Coordinadora de Quirofano
Administracion de radiologia
Coordinador deCEYE
Jefe de Cirugia
Asistente de Contraloría
Asistente Lic. Mario Gonzalez
Gerente de Compras
NA
Director
Contadora
Encargado de RM
Jefe de Radiologia
Jefe de Biomedica
NA
Jefa de CEyE de Otorrino y Oftalmo
Coordinadora de Quirófanos
Adquisiciones
Jefe de Adquisiciones
NA
Efa de Ceye de Ceniaq
NA
Ceye de CENIAQ
Evaluación Tecnológica
Jefe de la División de Imagenología
Jefe de CEyE
Jefe de Ceye y Ortopedia
Jefa de Qx de ORL y Oftalmología
Directora de Administración
Jefa de Enfermeras
Jefa de CEyE de ORL
Dirección de Cirugía
Subdirector de Compras y Suministros
Jefa de Ing. Biomédica
Jefa de Qx de Ortopedia
Jefa de almacen de Farmacia
Encargado de División Hospitalización
Encargada de Sala Qx de Artroscopia
División de Hospitalización
Jefa de Ceye de CENIAQ
Almacén
NA
NA
Adquisiciones
Enfermera Especialista
Enfermera
Med Adscrito Trauma
Jefe de TI
Director de Finanzas
Jefe de Radiologia
Tesorería
COMPRAS
Jefa de Enfermería
Jefe de Compras
Biomédica
DIRECTORA DE OPERACIONES
NA
Jefa de Calidad
Jefe de CEyE
Técnico de CEyE
Jefa de Qx
Técnico de CEyE
Técnico de CEyE
Técnico de CEyE
Jefe de Adquisiciones
Licenciada en Enfermería
Enfermera
Enfermera
Director Médico
Asistente Dirección de Operaciones
NA
Imagenologia
jefa de esterilizacion
Administrador de lapi Satelite
Enfermera de CEYE
Director General
Gerente de Sistemas
Gerente de Costos
Asistente de Control de Costos
NA
NA
Director TI
Administrador de PACS (Sistemas)
Gerente de Mantenimiento
Director de Juridico
Qx Corta Estancia
Responsable de consignación de navajas
Direción Administrativa
Jefe de Radiologia
juridico
Instrumentista
Gerente de enfermeria
Compras
Director Administrativo
jefa CEYE de policlinica
Gerente de computo
Biomedico
Compras
Jefe de Ingenieria Biomédica
Compras
Jefe de CEYE
Asistente del Lic. Cesar Suárez
Ing. Biomédico
Supervisor Ceye
Admon.Unidad Hospitalaria Infantil
Supervisora de Ceye
Técnico en Ceye
Jefe del Departamento de Compras
Jefe de Adquisiciones
Jefe de Almacén General
Enfermera Asistente de la CEyE
Jefe de Mantenimiento
Coordinador Tecnico de Adquisiciones
Subdirector Administrativo
Director de Cirugía Plástica y Quemados
Informatica
Director Medico
Recursos Financieros
Usuario
Jefe de CEyE
Jefa de Enfermeras
Jefe del Departamento de Rayos X
Gerente de Servicios Medicos
Subdirector Médico
Jefa de Adquisiciones
Adquisiciones
Jefe de CEyE
Subdirectora Administrativa
Jefe de CEyE y Quirofano
Jefa de Compras
Jefe de RX
Asistente
Ingeniería Biomédica
Jefe de Imagen
epidemiologia
epidemiologia
Jefa de Enfermeras
biomedica
Jefe de Mantenimiento
Supervisora de Efermería
Jefa de Ceye
Subdirector Administrativo
Responsable de pagos
epidemiologia
Enf. Comité Infecciones Musocombiales
jefa de piso
Director Médico
Subdirectora Médica
Jefe de compras
Compras
Compras
NA
NA
Operaciones
Biomedica
NA
Jefe de Compras
NA
NA
NA
NA
Director General
Calidad
Ingeniera Biomédica
Médico Radiólogo
Contadora
Cuentas por pagar
Director de Operaciones
Jefe de Enfermeras
Director General
Compras
Epidemiología
Epidemiología
Mantenimiento
Encargado de CEyE
Responsable Sanitario Farmacia
Directora Médica
Encargado de Almacén
Jefa de Compras
Jefe de Enfermeras
Director Médico y Operaciones
Ing. Biomédica
Mantenimiento
Jefe de Compras
NA
Jefe de Sistemas Vespertino
Asistente de Dirección General
Compras
Jefe de CEYE
Asistente Biomedica
Jefa de Qx
Director Médico
Jefe de Compras
Jefe de Ing. Biomedica
Directora
NA
Jefe de almacén
Supervisora de Enfermería
compras
compras
Jefe de Sistemas
Biomedica
Jefe de Rayos X
Compras
Cuentas por pagar
Enfermera de Quirofano
Biomedica
Jefe CEyE
Caja chica
Jefe de Biomedica - Electromecánica
Jefe de Radiología e Imagen
Jefe de la Division Qx
Auxiliar de Compras
Jefe de Adquisiciones
Supervisora en Jefe de Enfermería
Jefa de CEyE
Jefe de la Division de Cx
Jefe de Mantenimiento
Jefa de Ultrasonido
Supervisor Area Civil
Informatica
Jefe de finanzas
Personal CEyE
Usuario CEyE
Jefe de Qx
Jefe de CEyE
Ayudante Técnico del Gerente de Prevención Médica
Departamento de Prevención Secundaria y Asistencia Social
Director de la Unidad Médica del Centro Administrativo
Epidemiologo de la Unidad Médica del Centro Administrativo
Unidad Médica del Centro Administrativo
NA
Servicio Ceye
Subdirectora Administrativa
Asistente
Coordinador de Enseñanza
Jefe de Quirofanos
Apoyo dirección de Enfermería
Directora de Enfermería
LEO ALAN GERMAN
NA
Servicio Ceye
Servicio Ceye
NA
Jefe de CEyE
Jefe de Medicina Preventiva
Medico Radiologo
Direccion de finanzas
Jefe de Biomédica
Biomedica
Jefe imagenología
NA
Jefe de Compras
Auxiliar de compras
Depto de Compras
Biomédico
Directora de Enfermería
Jefe de CEyE
Jefe de Sistemas
Director de Finanzas
Gerente de Operaciones
Depto de compras
Enfermera Ceye
Jefe de Compras
Supervisor de Almacen
Asistente de operaciones
Director General
Jefe Biomédica
Ceye
biomedica
Jefa de Adquisiones
Jefa de Ceye
Enfermera ceye turno matutino
Coordinadora Clinica de la Subdireción de Enfermería
Personal de CEYE
Supervisora de Enfermeria
Jefa del Departamento de Insumos Hospitalarios
NA
Recursos materiales
Coordinadora de Insumos Hospitalarios
Jefa de Enfermeras
NA
Jefa de CEyE
Supervisora de Qx
Subdirector de Recursos Materiales
Asistente del Departamento de Bioingeniería
Enfermera a cargo de insumos
Enfermera General
Jefe del Departamento de Bioingeniería
Director General
Director General de Administración y Finanzas
Jefe de Compras
Jefe de almacén
Planeación Estratégica
Director Medico
Director de Sistemas
Asistente de Radiología
Jefa de Radiologia
Subdirectora de Administracion y Finanzas
encargado de ceye
Jefe de compras
Dra Adscrita
Dra Adscrita
Presidente Ejecutivo
INGENIERA BIOMEDICA
Sub director de Unidades Externas
Laboratorio de Patología Clínica (Director Médico)
Jefa de enfermeras
Ing. Biomédico
Responsable de Compras
Ing biomédica
Jefe de Ingenieria Biomédica
Ingeniería Biomédica
Compras equipo
Compras
Antes era Directora de Operaciones
Jefe de la Unidad de Radiología e Imagen
Director de Sistemas
Director General
Encargado del Sietema Ris y PACS
Directora de Cadena de Consumo
Depto. Ing Biomedica
Jefa de CEyE
Subdirectora de Ingeniería Biomédica
Ingeneira Biomédica
NA
Asistente de Dirección
Jefe de CEyE
Jefe de compras
Qx
Qx
CEyE
CEyE
CEyE
NA
NA
CEyE
Enfermera
Enfermero
Imagen
Jefe de Radiología
CEyE
CEyE
CEyE
Asistente de Direccion
Asistente de compras
Ya no está
Jefe de Ingeniería Biomédica
Ingeniería Biomédica
NA
Supervisora de CEYE
Comprador Corporativo
Gerente de Tecnologia de la Información
Director de compras
Director Corporativo de Recursos Materiales
Director de operaciones
Cuentas por pagar
Ejecutivo de Compras
Jefe de Unidad de Vigilancia Epidemiológica Hospitalaria
compras
Mastografia
Supervisor de Ingenieria Biomédica
Coordinador de Aplicaciones
Jefe de Quirofános y Enfermeras
Ing.Biomédico
Subjefe de Qx
Responsable de I Infraestructura
J CEyE
Ingeniería Biómedica
Epidemiología
Infecciones
JEFE DE IMAGEN
Compras
Coordinador Administrativo, Edificio de Investigaciones
Jefe de TI
Operación de Unidades Mixtas
Laboratorio de Genetica Forense
Investigacion
Jefe de la Unidad de Operación Administrativa de las Unidades Mixtas
Jefe de Radiologia
103
Subdirector de Asistencia Quirúrgica
Jefa de enfermeras de Qx
Jefa del Departamento de ingeniería biomédica
Jefa del departamento de epidemiología
Asistente epidemiología
Jefa de CEyE
Jefe del Depto Adquisiciones
Jefe de CEyE
CEyE
CEyE
Ing.Biomédico
CEyE
CEyE
NA
NA
Enfermera
Enfermera
Enfermera
Responsable de SubCEyE
Compras Gubernamentales Farmacéuticas
Enfermero
Asistente de Depto de Adquisiciones
Estudios de Mercado
Estudios de Mercado
Enfermería
NA
Compras
Dirección
Asistente Direccion
Jefe de Biomedica
JEFE DE MANTENIMIENTO
Imagen
Dirección de Administración y Finanzas
Administración
ing biomedico
NA
Atención a proveedores
Jefa de Biomedica (ya no trabajo ahí
Gerencia de Enfermería
Enfermera Qx
Jefa Ceye
Jefatura Quirófano
Jefa de Enfermeria
Jefe Biomedica
Encargada Ceye tarde
NA
Jefe CEyE
NA
NA
NA
Compras
Compras
Jefe de Biomédica
Director General Adjunto
Compras
Jefe de CEyE
Area de Imagen
Jefe de Cuentas por pagar
Jefatura de Cirugia
Gerente Corporativo de Compras
Coordinadora de Imagenologia
NA
Jefa de Enseñanza e Investigación Grupo Dalinde y Hospitales San Angelines
informática (TI)
Jefe de imágen
Jefe de almacén
Jefa de Quirófano
Gerente de Esterilización del Grupo Dalinde y Hospitales San Angelines
Jefe de Compras
Jefe de Ingeniería Biomédica
Sistemas
Jefe de Tecnovigilancia
Servicio Tecnico
SalesRep Merida
Tesoreria
NA
Admon ventas
Director de Finanzas
NA
NA
Director
C. P.
Specialist
NA
SalesRep
SalesRep
NA
NA
Gob
Atencion a clientes
Masto
Finanzas
Hermosillo Sonora
NA
NA
Contador
SalesRep
Servicio
Cobranza
NA
NA
SalesRep
Gobierno
NA
NA
Director Comercial
Director Administrativo
Ventas y Servicio
Gerente de Ventas Gobierno
Película
Compras y Almacén
Compras
Compradora y Ctas. por pagar
Compras
Coordinación de Enfermería
Coordinación General de Operaciones
Ing. Biomédico
Compras
Jefe de Quirofanos
CEyE
Gerente de Sucursal
Depto Ing. Biomédica
Auxiliar de Enfermería
Jefa de Enfermeras
Epidemiología
Jefe de Biomedica
Compras
NA
Director General
Jefe de Enfemería
X - Subdirector Médico
NA
NA
Administradora
Jefa de Qx y Ceye
Jefe de Compras
NA
Jefe de Calidad
Encargado de CEyE
Jefa de Qx y Hemodinamia
Técnico de CEyE
Enfermera
NA
NA
NA
NA
NA
Medico General
Ing. Biomédica
Radiologo
Socio Comercial
Administradora
Asistente
Directora General
NA
Técnico de Medicina Nuclear
Supervisor de Almacén
Biomedica
Director
Jefe de Radiología e Imagen
Jefa de Compras
Gerente Corporativo de Compras Sur y Universidad
Jefe de Medicina Nuclear
Jefe de Cirugia
Jefe de ceye
Jefe de quirofano
Dirección de Contraloría
Jefe de Sistemas
NA
Director de Proyectos SAP
Personal de Sistemas
Jefe de TI
Jefe de Unidades Clínicas
Jefe de Adquisiciones, Almacén e Inventarios
NA
Jefe de la Unidad de Clínicas Universitarias de Atención a la Salud
Director
SECRETARIA
Jefa de CEYE
Coordinador Finanzas
Recursos Financieros
Jefe de Imagenologia
Jefe de Almacen
Medico Radiologo
Jefe de TI
Subdirector Administrativo
Director Medico
Director
Ex Subdirector Administrativo
Jefe de Mantenimiento
Almacén
Almacén
Coordinadora Administrativa
encargado de la apertura de licitaciones
NA
NA
Veterinario
Gerente de Almacén / Logística
Inventory Analyst & SIOP
Instrumental
Regulatory Affairs
Gerente Región Norte
Director de Finanzas
Gerente de Asuntos Regulatorios
Inventory & Demand Supervisor (compras)
Jefe de Ceye
Cuentas por pagar
NA
Encargado área lavado instrumental
Director Comercial
NA
Compras
NA
NA
NA
ADMINISTRADOR
Ventas
NA
NA
NA
Gerente de Infraestructura y Mantenimiento
NA
Jefe de Contabilidad
Cuentas por pagar
Encargado de almacén
Subdirector Médico
Compras
NA
Encargado de CEyE Turno Vespertino
Jefe de CEyE
Jefe de Ingeniería Biomédica
Jefa de Qx
Jefa de Quirófano
Jefe de Suministros
Jefe de Imagen en Área de Imagen
Coordinadora de Suministros Hospitalarios
Gerente de Infraestructura y Mantenimiento
NA
Biomedica
Encargado Ceye
Encargado Ceye
Compras
Almacén
San Fernando nivel central Pacientes de segundo nivel
Contador corporativo
Auxiliar Administrativo
San Fernando nivel central Pacientes de primer contacto
Jefe de CEyE Turno Vespertino
Ing. Biómedica
NA
CEyE
CEyE
Encargado de CEyE Turno Matutino
Encargado de CEyE Turno Vespertino
Encargado de CEyE Turno Vespertino
Calidadd
NA
NA
Calidad
NA
Socia
NA
Jefe de Almacén
Jefe de Compras y Almacen
Jefe de Enfermería
Jefe de Cirugía
Responsable de CEyE
Jefe de Quirofanos
Jefe de CEyE
Jefe de CEyE y Quirofános
Compras
CEyE
Ingeniería Biomédica
Quirofanos
Subdirección de Sistemas y Operaciones
Responsable de CEyE
Compras
Cuentas por pagar
Técnico de CEYE
Director de Contraloría
NA
Jefe de Ceye
Jefe de Sistemas Informaticos
control de infecciones
jefe de imagen
Ingenieria Biomédica
Director
Directora de enfermería
Jefa de Quirófano
Coordinador de Ceye
Jefe de cuentas por pagar
Analista de Compras
Jefe de Compras
NA
Encargado CEYE en la defensa
NA
Compras
Responsable Compras
Encargada de Compras
Director General
Gerente Comercial
Ventas Gobierno
Coordinador de Servicios Integrales
COMPRAS
Coordinador
NA
NA
Jefe de CEyE HCM
NA
NA
NA
Prospecto de cambaceo
NA
Almacén
Cuentas por pagar
Coordinador
Coordinadora de Enfermería
Jefe de compras
NA
NA
NA
NA
NA
NA
NA
NA
Jefe de Cuentas por Pagar
Directora de Operaciones
Directora General y Directora Médica
Jefe de compras
Jefe de Biómedica
Jefe de Validación
Compras
NA
NA
Compras
Jefe de Qx
Gerente
Dirección General
Infecciones Nosocomiales
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)