using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-\s(.*)\n?";
string input = @"- Abonnement Standard
- Support Standard
- 2 Canaux
- Définition de la stratégie de ciblage par un chef de produit dédié
- Suivi mensuel des performances et optimisation de la stratégie de ciblage
- Configuration et intégration
- Personnalisation de l'intégration graphique (2 allers-retours) - Option Responsive
- Formation à distance - 2 heures - 5 personnes
- Option Genius Targeting
- Option Genius Answers";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}