import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "-\\s(.*)\\n?";
final String string = "- Abonnement Standard\n"
+ "- Support Standard\n"
+ "- 2 Canaux\n\n"
+ "- Définition de la stratégie de ciblage par un chef de produit dédié\n"
+ "- Suivi mensuel des performances et optimisation de la stratégie de ciblage \n"
+ "- Configuration et intégration\n"
+ "- Personnalisation de l'intégration graphique (2 allers-retours) - Option Responsive\n"
+ "- Formation à distance - 2 heures - 5 personnes\n"
+ "- Option Genius Targeting\n"
+ "- Option Genius Answers";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}