$re = '/^\/.*\/(?=\bapp\b)/m';
$str = '/User/username/Code/project/app/Controllers/MyClass.php
/User/username/Code/company_web_app/app/Controllers/MyClass.php';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);