re = /\bInternet\b(?=(?:[^"]*"[^"]*")*[^"]*$)/im
str = 'Internet "InternetFormula works and it\'s internetformula"
Internet "The internet works"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end