# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\R*$/•/u;t' <<< "line
line 2
line 3
NOTE: The replacement uses a bullet
instead of a LF so it is easy to see
"