using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(textarea)([^>]+)>([^%]*?)<\/\1>";
string input = @"<p>
<textarea class=""ckeditor-basic"" cols=""100"" name=""textAreaName"" required=""required"" rows=""5"">
<p>5051950</p>
</textarea>
</p>
<p><textarea class=""ckeditor-basic"" cols=""100"" name=""textAreaName"" required=""required"" rows=""5""></textarea></p>
<p><textarea class=""ckeditor-basic"" cols=""100"" name=""textAreaName"" required=""required"" rows=""5""></textarea></p>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}