using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"20[0-9]{2}[01][0-9][0123][0-9]";
string input = @"20160339
20130123
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}