const regex = /([^\d.]+)(\d[\d.e+-]*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\d.]+)(\\d[\\d.e+-]*)', 'g')
const str = `Height_A_B132width_top100.0lengthsimple0.00001
Height_A132width_top100.0lengthsimple1.34e+003
be12`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}