const regex = /[A-Z]+(\d+)_[A-Z]+_[A-Z]+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Z]+(\\d+)_[A-Z]+_[A-Z]+', '')
const str = `BREAK1_UPPER_QUANTITY`;
const subst = `Staffel \1 Obergrenze`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);