#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Umbra-[\d]{2,}+"
Local $sString = "Umbra-9" & @CRLF & _
"umbra-09" & @CRLF & _
"Umbra_09" & @CRLF & _
"Umbra09" & @CRLF & _
"UMBRA-09" & @CRLF & _
"Umbra-09" & @CRLF & _
"Umbra-10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")