using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Umbra-[\d]{2,}+";
string input = @"Umbra-9
umbra-09
Umbra_09
Umbra09
UMBRA-09
Umbra-09
Umbra-10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}