// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Umbra-[\d]{2,}+").unwrap();
let string = "Umbra-9
umbra-09
Umbra_09
Umbra09
UMBRA-09
Umbra-09
Umbra-10";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}