package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\((.*?)\)[^?]`)
var str = `(need to capture including brackets) ignore this
(ignore this completely)?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}