$re = '/\((.*?)\)/m';
$str = '(need to capture including brackets) ignore this
(ignore this completely)?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);