$re = '/([A-Za-z.\/-]+)|([^A-Za-z.\/-]+)/';
$str = 'ABCD123
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;