#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\033\[(?:\d+;\d+[Hf]|\d+[A-D]|[suK]|2J|\d+(?:;\d+)*m)"
Local $sString = "[K" & @CRLF & _
"[1;4;41;37m" & @CRLF & _
"[0m" & @CRLF & _
"[42A" & @CRLF & _
"[2J" & @CRLF & _
"[2;3H"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")