package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(\/\/(.*?)\n)|(\/\*(.*?)\*\/)`)
var str = `/* комментарий */
init: function(options)
{
opts = $.extend({}, defaults, options);
opts._this = $(this).attr('id');
opts.elementWrapper = $('#' + opts.resultItemWrapper).
/*
* комментарий
*/
prop('outerHTML').
replace(/\s+/g, ' ');
$(this).children().remove();
$(this).css({'height': '100%'});
// $(this).append
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}