# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?=.*")-%|(?=.*")%-/%/gm;t' <<< "{%- assign foo = true -%}
<span class=\"{%- if foo == true -%} blue{%- else -%} red{%- endif -%}\">item</span>"