package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Z]{2,3}|[0-9]{4}`)
var str = `find ABCD1234
DTD0001`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}