$re = '/(^[0-9]+)(?!.* )/m';
$str = 'WORD
66B
75
84 SOMETHING
1-2
888/5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);