$re = '/(?<=^|>).*?(?=<|$)/s';
$str = '<html>
<body>
<h1>Hello World!</h1>
<p>
This is a page to <i>test</i>the regexp.<br/>
It seem to work.
</p>
</body>
</html>Text at the end is also removed.
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;