using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\[(?P<string1>.*?)\])\s*(?P<string2>[^\(]*)\s*(\((?P<string3>.*)\))?";
string input = @"[string1...] string2 in english/chinese (string3...)?
[string1...] string2 in english/chinese
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}