$re = '/([\w+.]+@[\w.-]+)/';
$str = 'All of these emails should be valid (matched by the Regex):
tes.t@gmail.co.uk
q@q.com
a+2@gmail.com
+sd@gmail.com
a++abc@gmail.com
asdf.asdf@test-dom-a.com
All of these emails should be INVALID:
·$(")@gmail.com
(((@q.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);