$re = '@(www\.|http://)([a-zA-Z0-9\/?\-&=_\.]+\.com|\.net|\.org|\.ca)(/[a-zA-Z0-9/?\-_&=\.]*)?@';
$str = 'This is a stupid site: www.etsy.com and etc
This is a stupid video http://www.youtube.com/watch?v=MkXVM6ad9nI and etc';
$subst = "<a href='$1$2$3'>$1$2$3</a>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;