$re = '/(?is)<input(?![^>]+type=)[^>]+>/';
$str = '<input name="a" type="button" />
<input name="b">
<input type="button" name="c">
<input type="button" name="d">
<input name="e">
<input name="f" type="button">
<input name="g">';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);