import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+:\\s+(\\d+(?:\\.\\d+))\\s+(\\w+)\\s+.*$";
final String string = "Spysannya z depozytu Suma: 10000.00 UAH Kod avtoryzatsii: 841738 Diysnyi do 15:42:52";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}