$re = '/GET \/someportal\/rest\/product\/v1_0\/.*\/filename\/(?<FileName>\S+)/m';
$str = 'GET /someportal/rest/product/v1_0/clientidentifier/filename/fnm_123456789abcd.png HTTP/1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);