re = /{{If(?!.*?{{If).*?{{EndIf}}/
str = '{{If "{{Line}}" != ""}}
{{If "{{Line}}" != ""}}
<li id="{{Required:Id}}" class="menuEntry line">
{{EndIf}}
<li id="{{Required:Id}}" class="menuEntry line">
{{EndIf}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end