use strict;
my $str = '--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154
Content-Transfer-Encoding: 7bit
Content-Type: text/plain;
charset=us-ascii
Cordialement.
Non prenom
--Apple-Mail=_380D7683-C2AA-4F13-8B31-93C43592D154
Content-Disposition: attachment;
filename="mes candidatures.txt"
Content-Type: text/plain;
name="mes candidatures.txt"
Content-Transfer-Encoding: quoted-printable
ici la piece jointe en texte B64';
my $regex = qr/filename=\"(\w*.*)"/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}