import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span([^<]*)>(.*?)<\\/span>";
final String string = "<p>Given <span class=\"label\">Butter's game, the tree counts as more than one input.</p>\n"
+ "<p>Given <span class=\"label\">Butter'</span>;s game, the tree counts as more than one input.</p>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}