$re = '/<span([^<]*)>(.*?)<\/span>/m';
$str = '<p>Given <span class="label">Butter's game, the tree counts as more than one input.</p>
<p>Given <span class="label">Butter'</span>;s game, the tree counts as more than one input.</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);