#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)([\S ]+)(\n*)([\s\S]*?)Bar([\s\S]*?)Baz([\s\S]*?)"
Local $sString = "Foo 1" & @CRLF & _
"foo1Text" & @CRLF & _
"" & @CRLF & _
"Bar" & @CRLF & _
"bar1Text" & @CRLF & _
"" & @CRLF & _
"Baz" & @CRLF & _
"baz1Text" & @CRLF & _
" " & @CRLF & _
"Foo 2" & @CRLF & _
"foo2Text" & @CRLF & _
"" & @CRLF & _
"Bar" & @CRLF & _
"bar2Text" & @CRLF & _
"" & @CRLF & _
"Baz" & @CRLF & _
"baz2Text" & @CRLF & _
"" & @CRLF & _
"# and so on up to Foo/Bar/Baz N"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")