# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"([\S ]+)(\n*)([\s\S]*?)Bar([\s\S]*?)Baz([\s\S]*?)"
test_str = ("Foo 1\n"
"foo1Text\n\n"
"Bar\n"
"bar1Text\n\n"
"Baz\n"
"baz1Text\n"
" \n"
"Foo 2\n"
"foo2Text\n\n"
"Bar\n"
"bar2Text\n\n"
"Baz\n"
"baz2Text\n\n"
"# and so on up to Foo/Bar/Baz N")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.