#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:(\+)?(1)?([-(.])?([1-9]\d{2})([-).])?\s?([1-9]\d{2})([-.])?(\d{4})|([1-9]\d{2})([-.])?([1-9]\d{2})([-.])?(\d{4})|([1-9]\d{2})([-.])?(\d{4}))"
Local $sString = "1-800-555-1212" & @CRLF & _
"" & @CRLF & _
"+1-800-555-1212" & @CRLF & _
"" & @CRLF & _
"1(800)555-1212" & @CRLF & _
"" & @CRLF & _
"800-555-1212" & @CRLF & _
"" & @CRLF & _
"800.555.1212" & @CRLF & _
"" & @CRLF & _
"555-1212" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")