re = /user-type=\s+:(\w+)!.*:([\S\s]+)/
str = 'badges: @badges=;color=;display-name=;emotes=;message-id=34;thread-id=5575526_123681740;turbo=0;user-id=5575526;user-type= :teonnyn!teonnyn@teonnyn.tmi.twitch.tv WHISPER blastweb :Hello Bot'
# Print the match result
str.match(re) do |match|
puts match.to_s
end