# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?[\['](.*?\(Delete\).*?)[\]'].*/\1/g;t' <<< "blah blah [manikv (Delete) 4916258] blah blah
blah blah 'morl20 (Delete) 180977' blah blah"