// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*?[\['](.*?\(Delete\).*?)[\]'].*").unwrap();
let string = "blah blah [manikv (Delete) 4916258] blah blah
blah blah 'morl20 (Delete) 180977' blah blah";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}