$re = '/^(?:\s+[A-Za-z0-9]+)+\s+$/m';
$str = ' Test this stuf
Test
Test ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);