# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.{5})((.*?)([0-9])(.*?)([0-9])(.*)|(.{11})(.)(.)(.*))(.{5})$/$1$3$6$5$4$7$8$10$9$11$12/gm;t' <<< "h8lcmrhh2m9vq4gkogvlokf4k2
abcde12345fghij67890
1a2b3c4d5e6f7g8h9i0j1k2l3m
34gf7asjkabaa4sfdlencxnkil9qrx"