import Foundation
let pattern = #"^(.{5})((.*?)([0-9])(.*?)([0-9])(.*)|(.{11})(.)(.)(.*))(.{5})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
h8lcmrhh2m9vq4gkogvlokf4k2
abcde12345fghij67890
1a2b3c4d5e6f7g8h9i0j1k2l3m
34gf7asjkabaa4sfdlencxnkil9qrx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$3$6$5$4$7$8$10$9$11$12"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)