$re = '/^.{12}\KTest(?!(?:added|deleted)\b).*$/mi';
$str = '1234567890ABTest
ABC4567890ABTestadded
ABC4567890ABTest2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);