using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\\)[^\\]*\\[^\\]*$";
string input = @"D:\Archive Directory\2015-12-31 PM\SerialNo_01
D:\Archive Directory\2016-01-01\SerialNo_02
D:\Archive Directory\January 2016\SerialNo_03";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}