use strict;
my $str = 'create myclass "56, \'for the better or worse\', 54.781"';
my $regex = qr/\s(?=(?:[^"]*"[^"]*")*[^"]*$)/mp;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";