const regex = new RegExp('(?:\\"(?:errorType)\\"(?:[^:])*):(?:(?:[^\\",])*)\\"([^\\"]*)', 'g')
const str = `{
"data": null,
"errors": [
{
"message": "Message",
"extensions": {
"errorType": "UNKNOWN",
"error_code": "AUTHENTICATE_USER_FALSE"
}
},
{
"message": "Message",
"extensions": {
"errorType": "UNAUTHENTICATED",
"error_code": "AUTHENTICATE_USER_FALSE"
}
}
]
}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}