re = /(?>.*?\=)(.*)(?>.*?\|)(?>.*?\=)(.*)(?>.*?\|)(?>.*?\=)(.*)/m
str = 'section=library|object=photography|id=79483'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end