#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"School\s*=\s*(?P<school_name>.+)" & @CRLF & _
"(?P<school_content>[\s\S]+?)" & @CRLF & _
"(?=^School|\Z)"
Local $sString = "Sample text" & @CRLF & _
"" & @CRLF & _
"A selection of students from Riverdale High and Hogwarts took part in a quiz. This is a record of their scores." & @CRLF & _
"" & @CRLF & _
"School = Riverdale High" & @CRLF & _
"Grade = 1" & @CRLF & _
"Student number, Name" & @CRLF & _
"0, Phoebe" & @CRLF & _
"1, Rachel" & @CRLF & _
"" & @CRLF & _
"Student number, Score" & @CRLF & _
"0, 3" & @CRLF & _
"1, 7" & @CRLF & _
"" & @CRLF & _
"Grade = 2" & @CRLF & _
"Student number, Name" & @CRLF & _
"0, Angela" & @CRLF & _
"1, Tristan" & @CRLF & _
"2, Aurora" & @CRLF & _
"" & @CRLF & _
"Student number, Score" & @CRLF & _
"0, 6" & @CRLF & _
"1, 3" & @CRLF & _
"2, 9" & @CRLF & _
"" & @CRLF & _
"School = Hogwarts" & @CRLF & _
"Grade = 1" & @CRLF & _
"Student number, Name" & @CRLF & _
"0, Ginny" & @CRLF & _
"1, Luna" & @CRLF & _
"" & @CRLF & _
"Student number, Score" & @CRLF & _
"0, 8" & @CRLF & _
"1, 7" & @CRLF & _
"" & @CRLF & _
"Grade = 2" & @CRLF & _
"Student number, Name" & @CRLF & _
"0, Harry" & @CRLF & _
"1, Hermione" & @CRLF & _
"" & @CRLF & _
"Student number, Score" & @CRLF & _
"0, 5" & @CRLF & _
"1, 10" & @CRLF & _
"" & @CRLF & _
"Grade = 3" & @CRLF & _
"Student number, Name" & @CRLF & _
"0, Fred" & @CRLF & _
"1, George" & @CRLF & _
"" & @CRLF & _
"Student number, Score" & @CRLF & _
"0, 0" & @CRLF & _
"1, 0" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")